HP Envy 4520 Printer System Requirement

123.hp.com/envy4520 printer system requirements are given below. The system requirements for the operating systems varies accordingly. Choose the Operating system and follow the guidelines for particular operating systems like Linux, OS X and Windows.

  1. Linux system requirements

Review the information and check whether your 123.hp.com/envy4520 printer is compatible with the Linux operating system

Initially check whether you have Linux kernel 2..4.19 and later version. The recommended Linux kernel version is 2.6x

To build from the source code GNU software tools are required.  It includes ANSI C++ compiler, ANSI C compiler and POSIX compliant environment.

You need libusb 0.1..8 or higher and GPL Ghostscript is 7.05 or  higher. Foomatic 3.0.2 or higher and Qt 3.x or higher for UI toolkit. PyQt 3.14 or higher for Qt wrapper for Python. Python 2.2 or higher and python-devel (Python 2.3+ for fax support)

You also need CUPS DDK 1.2 or higher for dynamic PPD support and Net-snp 5.0.9 or higher net-snmp-devel for network support.

CUPS 1.1.15 or higher and cups-devel. You also need libjpeg 6b or higher and libjpeg-devel

2. OS X system requirement

The free disk space is 1 GB, The USB port is required and  internet access is also required.  The minimum system requirements for Mac operating systems are given for OS X v10.9 Mavericks, OS X v10.10 Yosemite, and OS X v10.11 El Capitan

3. Windows system requirements

In Windows 8, the minimum system requirements are 1 processor, 1 GB RAM, 2 GB of free disk space. The recommended system requirements are 1.5 GHz  processor, 2 GB RAM,  2GB of free disk space. The recommended system requirements are Microsoft Internet Explorer 8.0 or later; FireFox and Google Chrome other requirements are CD-ROM or DVD drive or Internet connection , USB port and Adobe Acrobat Reader 5.0 or later.

 

In Windows 10, the minimum system requirements are 1 GHz processor, 1 GB of RAM and 2GB of free disk space.  The recommended system requirements are 1.5 GHz  processor, 2 GB of RAM and 2.5 GB of free disk space. The required browsers are Microsoft Internet Explorer 8.0 or later; FireFox and  Google Chrome other requirements are CD-ROM or DVD drive or Internet connection , USB port and Adobe Acrobat Reader 5.0 or later.

123-hp-envy4520-printer-system-requirement
123-hp-printer-support